Kaseya VSA Hack
Incident Report for AYN
Resolved
At approximately 8 pm UK time Friday 2nd of July, we were notified of a hack involving the very popular and market-leading remote management tool from Kaseya. The exact details are still a bit sketchy but it appears as though the attack has targeted on-premise VSA Kaseya customers mainly in the USA.

Due to the serious nature of the hack, an immediate response was taken by Kaseya to shut down all VSA services they host for companies like ourselves and advising on-premise customers to shut their own servers down with immediate effect.

We have had a long night reviewing our client systems and working with other MSPs to check and I'm happy to report that all looks well.

The issue does appear to be limited to the on-premise VSA which we don't use.

Official information can be found here: https://www.kaseya.com/potential-attack-on-kaseya-vsa

We will be continuing to review the situation as more information comes to light and don't want to jump to any conclusions as to the cause until the full diagnosis has been made available.

UPDATE 05/07/2021: No SaaS VSA's appear to have been affected however the SaaS infrastructure remains offline making support processes slower than normal.
Posted Jul 02, 2021 - 20:00 BST