Microsoft reporting a 365 issue affecting one or more services in the UK
Incident Report for AYN
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 13:46 GMT
Investigating
Microsoft are investigating reports of an issue where users may be unable to access 365 services in the United Kingdom. See https://status.office.com for further updates.
Posted Mar 11, 2021 - 07:33 GMT
This incident affected: Asyouneed 3rd Party Services.